1) Forums : Technical Support : Win10 Update Causes Problem? (Message 21182)
Posted 23 Sep 2016 by Larry
Post:
All hail Marius! Haha! Honestly, though, your information was right on the mark. My next batch of jobs had arrived, and all halted in the same fashion. Checking those links you provided, I did the following:

1. Uninstalled my VirtualBox 5.0.10.

2. Rebooted Win 10 (probably not necessary, but it used to be in older Win versions).

3. Ran my favorite registry cleaner (CCleaner) just to remove any VBox "remnants" from the Win 10 registry (again, probably not necessary as the only obvious remnant I noticed was the application path reference).

4. Installed VirtualBox 5.1.6 (tried VBox 5.0.10 initially -- all WU's "reset," but halted in same fashion) using "Run as administrator" [option menu] selection.

All camb_boinc2docker WU's are now executing properly. I have verified that WU progress has exceeded that "critical point" of approximately 24.25%. And in fact, some WU's have completed during the time it took me to enter this post.

Thanks again Marius. Bottom line seems to be upgrade to VirtualBox 5.1.x after first uninstalling the older version. Uninstalling is probably the critical link in the process to ensure the used COM libraries are unregistered prior to re-install.
2) Forums : Technical Support : Win10 Update Causes Problem? (Message 21180)
Posted 22 Sep 2016 by Larry
Post:
Indeed, unfortunately, I spoke too soon. Upon each job being queued to continue running, all halted with the same original error message.

I will abort my current batch of camb_boinc2docker WU's and await the next batch to see what happens. I'll report back then.
3) Forums : Technical Support : Win10 Update Causes Problem? (Message 21175)
Posted 22 Sep 2016 by Larry
Post:
After submitting my previous post [yesterday], I checked the BOINC Manager Event Log and noticed additional detail stating that each of the 11 tasks on my machine were postponed for 86400.000000 seconds (24 hours) for the error: "VM Hypervisor failed to enter an online state in a timely fashion."

So I waited 24 hours, and all seems back to "normal." Since I run multiple projects on my machine, the current status of all my camb_boinc2docker jobs happens to be "Waiting to run (2 CPUs)."

Whatever the original issue was, task postponement seems to have resolved it.
4) Forums : Technical Support : Win10 Update Causes Problem? (Message 21172)
Posted 21 Sep 2016 by Larry
Post:
I just upgraded my Win 10 to the Anniversary Edition today, and am experiencing the same problem (as originally described in this thread) for each of the 11 WU's/tasks currently on my machine. Most of the tasks made it to approximately 24.25% completion per the Progress indicator before halting with the same error as listed in the original post to this thread. Not that it appears to matter, but my VirtualBox version is 5.0.10. Coincidentally, I have also restricted camb_boinc2docker jobs to 2 CPU's.

Any new thoughts?
5) Forums : Technical Support : Still getting camb_legacy (Message 20700)
Posted 6 Jan 2016 by Larry
Post:
All I did was disable the camb-legacy application from running (unless no work for camb_boinc2docker is available) within my account Cosmology@Home Project Preferences configuration.
6) Forums : Technical Support : app_config.xml Error (Message 20699)
Posted 6 Jan 2016 by Larry
Post:
Thanks Cwill_CZ, but my problem was fixed by saving my app_config.xml file in ANSI format (and using only the <avg_ncpus>1</avg_ncpus> option without the <max_ncpus>1</max_ncpus> option which is not available to app_config.xml).

And, I only need this file specifically for use with the camb_boinc2docker application as a means of restricting multiple/concurrent CPU core usage per job/task/WU within the VirtualBox environment as described in the current project FAQ. This "CPU behavior" is not an issue with the camb_legacy application (and is a completely different issue from that addressed by the <max_concurrent>X</max_concurrent> configuration option that you have included in your sample file).
7) Forums : Technical Support : slow gpu (Message 20657)
Posted 26 Dec 2015 by Larry
Post:
So..., what is the procedure for using "Prio" to set the process of VBoxSVC to "Low?"
8) Forums : Technical Support : app_config.xml Error (Message 20625)
Posted 2 Dec 2015 by Larry
Post:
Thanks for the update and clarification. I'll be ready to use an app_info.xml file if my current app_config.xml fails to implement the project execution configuration that I desire.

The FAQ [item] I'm referring to is the one for this project: How can I limit the number of CPUs used?
9) Forums : Technical Support : app_config.xml Error (Message 20621)
Posted 2 Dec 2015 by Larry
Post:
Nice catch, Jord/Ageless! Thank-you. Re-saving the file in ANSI format corrected the original error. As I would expect now, though (until the new application download becomes available on Dec 3), I'm receiving the following error upon project initialization:

"Your app_config.xml file refers to an unknown application 'camb_boinc2docker'. Known applications: 'camb'"

Regarding your configuration file/option requirement reference, I'll see what happens after I accept at least one new job (and Docker container) prior to restarting my BOINC client, for which the specified configuration should be implemented on subsequent jobs. It would seem according to that referenced BOINC documentation, that the <avg_ncpus>x</avg_ncpus> option in app_config.xml provides the same intended limitation as does the <max_ncpus>x</max_ncpus> option in app_info.xml. I suppose regardless, though, if indeed <max_ncpus>x</max_ncpus> isn't [yet] an option in application configuration, app_config.xml, but rather only in anonymous platform, app_info.xml, then a change to the FAQ needs to be made immediately.
10) Forums : Technical Support : app_config.xml Error (Message 20618)
Posted 2 Dec 2015 by Larry
Post:
I created the following app_config.xml file (to restrict CPU multi-threading since I run multiple projects on a 4-core CPU) and placed it in my Cosmology@Home project directory:

<app_config>
    <app>
        <name>camb_boinc2docker</name>
        <max_concurrent>1</max_concurrent>
    </app>
    <app_version>
        <app_name>camb_boinc2docker</app_name>
        <plan_class>vbox64_mt</plan_class>
        <avg_ncpus>1</avg_ncpus>
        <max_ncpus>1</max_ncpus>
    </app_version>
</app_config>


However, upon restarting BOINC I receive the following [Event Log] error when this project initializes: Missing <app_config> in app_config.xml.

What's my problem?