Advanced search

Forums : Technical Support : Upload/Download Server Problems
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3 · 4 · 5 · 6 . . . 9 · Next

AuthorMessage
Profile Scott
Volunteer moderator
Project administrator
Project developer
Avatar

Send message
Joined: 1 Apr 07
Posts: 662
Credit: 13,742
RAC: 0
Message 4615 - Posted: 24 Jan 2008, 5:58:50 UTC
Last modified: 24 Jan 2008, 6:06:16 UTC

Here\'s the scoop: apache is redirecting the traffic to the new server, but the actual request is being lost during the redirect. I\'m trying to figure out a way to make apache send everything, but apparently nobody has ever had this problem (or at least they didn\'t post about it anywhere).

Also: when a redirect is made, the current HTTP session is lost, and it is up to the original requester to make another request. So, not that I\'m pointing fingers, but this would be a lot easier if the boinc client would check for a redirect request. Hooray for error handling!
Scott Kruger
Project Administrator, Cosmology@Home
ID: 4615 · Report as offensive
Profile Ananas

Send message
Joined: 19 Jan 08
Posts: 180
Credit: 2,500,290
RAC: 0
Message 4620 - Posted: 24 Jan 2008, 7:07:07 UTC
Last modified: 24 Jan 2008, 7:07:37 UTC

Problems are partially caused by a BOINC bug as well. It does know the new URL, but instead of adjusting it, it keeps using the old one and nags about it. Those Berkeley guys have some weird (or no?) concepts.
ID: 4620 · Report as offensive
Profile Scott
Volunteer moderator
Project administrator
Project developer
Avatar

Send message
Joined: 1 Apr 07
Posts: 662
Credit: 13,742
RAC: 0
Message 4622 - Posted: 24 Jan 2008, 7:10:42 UTC
Last modified: 24 Jan 2008, 7:14:21 UTC

http://cosmologyathome.org/forum_thread.php?id=21&nowrap=true#4621

I may end up checking in a change to the client code that looks for a redirect request so that other projects won\'t run into this same issue in the future.
Scott Kruger
Project Administrator, Cosmology@Home
ID: 4622 · Report as offensive
Profile Scott
Volunteer moderator
Project administrator
Project developer
Avatar

Send message
Joined: 1 Apr 07
Posts: 662
Credit: 13,742
RAC: 0
Message 4623 - Posted: 24 Jan 2008, 7:15:14 UTC

Also: I am going to bed for now, but I\'ll be around tomorrow.
Scott Kruger
Project Administrator, Cosmology@Home
ID: 4623 · Report as offensive
Brian Silvers

Send message
Joined: 11 Dec 07
Posts: 420
Credit: 270,580
RAC: 0
Message 4624 - Posted: 24 Jan 2008, 7:19:47 UTC - in response to Message 4622.  
Last modified: 24 Jan 2008, 7:22:14 UTC

http://cosmologyathome.org/forum_thread.php?id=21&nowrap=true#4621

I may end up checking in a change to the client code that looks for a redirect request so that other projects won\'t run into this same issue in the future.


Based on these messages, I am using www.cosmologyathome.org, which supposedly will work sometime within the next 12-18 hours... If so, then all I need to do is sit tight and not do anything as far as network traffic, and when the www-based URL comes online, the application should auto-upgrade. Correct?

1/24/2008 1:56:07 AM|Cosmology@Home|URL: http://www.cosmologyathome.org/; Computer ID: 10466; location: home; project prefs: default
1/24/2008 2:10:02 AM|Cosmology@Home|Sending scheduler request: Requested by user
1/24/2008 2:10:02 AM|Cosmology@Home|(not requesting new work or reporting completed tasks)
1/24/2008 2:10:07 AM|Cosmology@Home|Scheduler RPC succeeded [server version 601]
1/24/2008 2:10:07 AM|Cosmology@Home|You used the wrong URL for this project
1/24/2008 2:10:07 AM|Cosmology@Home|The correct URL is http://cosmologyathome.org/
1/24/2008 2:10:07 AM|Cosmology@Home|Using the wrong URL can cause problems in some cases.
1/24/2008 2:10:07 AM|Cosmology@Home|When convenient, detach this project, then reattach to http://cosmologyathome.org/
1/24/2008 2:10:07 AM|Cosmology@Home|Message from server: Incomplete request received.
1/24/2008 2:10:07 AM|Cosmology@Home|New host venue: 
1/24/2008 2:10:07 AM|Cosmology@Home|Deferring communication for 6 sec
1/24/2008 2:10:07 AM|Cosmology@Home|Reason: requested by project

ID: 4624 · Report as offensive
Profile John Hunt
Avatar

Send message
Joined: 6 Jul 07
Posts: 186
Credit: 257,584
RAC: 0
Message 4626 - Posted: 24 Jan 2008, 7:31:26 UTC


I have detached and then re-attached successfully using the URL Scott has stated. In the process, I have consigned to cyberspace 10 completed WUs, 3 x 50% completed and 2 ready to start. I\'m not worried about sending a list of the completed WUs - Scott has enough work on his hands without me chasing up a few credits!


ID: 4626 · Report as offensive
Profile Webmaster Yoda

Send message
Joined: 28 Jun 07
Posts: 21
Credit: 1,632,327
RAC: 0
Message 4637 - Posted: 24 Jan 2008, 10:47:23 UTC

I too decided to just detach and re-attach on my 7 computers. May have lost about 24 hours of fully and partially crunched work units but I can live with that.

I did go through and update client_state.xml etc on a couple of computers and managed to upload and report, but can\'t be bothered doing it on all of them.
ID: 4637 · Report as offensive
laurenu2

Send message
Joined: 1 Sep 07
Posts: 15
Credit: 5,614,260
RAC: 0
Message 4655 - Posted: 24 Jan 2008, 14:44:04 UTC - in response to Message 4592.  

Ok its working again...however now I got this :
Wed 23 Jan 2008 08:58:03 PM CST|Cosmology@Home|Giving up on upload of wu_012008_121054_0_0_0: server rejected file
Wed 23 Jan 2008 08:58:03 PM CST|Cosmology@Home|[file_xfer] Permanently failed upload of wu_012008_121054_0_0_3
Wed 23 Jan 2008 08:58:03 PM CST|Cosmology@Home|Giving up on upload of wu_012008_121054_0_0_3: server rejected file

So anything that was trying to upload since the maint. is now failing

Strange... the server is telling me that WU was successfully uploaded, but is considered \"inconclusive\" so far.

At any rate (and this goes for everybody), send me a PM with a list of ids of lost results, and I will try my best to grant them all credit. Again, sorry for the confusion.

What you are asking from me is a immense job. For me to go to 80 + PC\'s an pull the info from the log file will take Hours of work for me and it does not save the work I did. I guess I Lost a 1/4 of a year of PC time in your mess-sup NOT GOOD
If You Want The Best You Must forget The Rest
>>>>>>>>>>>>>And Join Free-DC<<<<<<<<<<<<<<<<
ID: 4655 · Report as offensive
Profile S@NL - Mellowman
Avatar

Send message
Joined: 20 Nov 07
Posts: 40
Credit: 469,070
RAC: 0
Message 4660 - Posted: 24 Jan 2008, 15:57:18 UTC
Last modified: 24 Jan 2008, 16:00:41 UTC

Lost about 1-2 days of work while thinking the problem was on my end. Resetting the projhect didn\'t seem to work so I reattached. Still having problems though so I checked here.

After re-attaching to \'http://cosmologyathome.org\' I\'m getting these errors but the WU\'s seem to report ok and give credit:
Jan/24/2008 05:19:49|Cosmology@Home|Started upload of wu_011208_110500_2_0_0
Jan/24/2008 05:19:49|Cosmology@Home|Started upload of wu_011208_110500_2_0_1
Jan/24/2008 05:19:51|Cosmology@Home|[error] Error on file upload: no command
Jan/24/2008 05:19:51|Cosmology@Home|[error] Error on file upload: no command
Jan/24/2008 05:19:51|Cosmology@Home|Giving up on upload of wu_011208_110500_2_0_0: fatal upload error
Jan/24/2008 05:19:51|Cosmology@Home|Giving up on upload of wu_011208_110500_2_0_1: fatal upload error
Jan/24/2008 05:19:51|Cosmology@Home|Started upload of wu_011208_110500_2_0_2
Jan/24/2008 05:19:51|Cosmology@Home|Started upload of wu_011208_110500_2_0_3
Jan/24/2008 05:19:53|Cosmology@Home|[error] Error on file upload: no command
Jan/24/2008 05:19:53|Cosmology@Home|[error] Error on file upload: no command
Jan/24/2008 05:19:53|Cosmology@Home|Giving up on upload of wu_011208_110500_2_0_2: fatal upload error
Jan/24/2008 05:19:53|Cosmology@Home|Giving up on upload of wu_011208_110500_2_0_3: fatal upload error
Jan/24/2008 05:19:53|Cosmology@Home|Started upload of wu_011208_110500_2_0_4
Jan/24/2008 05:19:53|Cosmology@Home|Started upload of wu_011208_110500_2_0_5
Jan/24/2008 05:19:55|Cosmology@Home|[error] Error on file upload: no command
Jan/24/2008 05:19:55|Cosmology@Home|[error] Error on file upload: no command
Jan/24/2008 05:19:55|Cosmology@Home|Giving up on upload of wu_011208_110500_2_0_4: fatal upload error
Jan/24/2008 05:19:55|Cosmology@Home|Giving up on upload of wu_011208_110500_2_0_5: fatal upload error
Jan/24/2008 05:20:00|Cosmology@Home|Sending scheduler request: To report completed tasks. Requesting 0 seconds of work, reporting 1 completed tasks
Jan/24/2008 05:20:05|Cosmology@Home|Scheduler request succeeded: got 0 new tasks


Anthony.


The longer I live, the more reasons I develop for wanting to die.
ID: 4660 · Report as offensive
Fred

Send message
Joined: 17 Jan 08
Posts: 40
Credit: 228,230
RAC: 0
Message 4661 - Posted: 24 Jan 2008, 16:17:34 UTC - in response to Message 4660.  

Lost about 1-2 days of work while thinking the problem was on my end. Resetting the projhect didn\'t seem to work so I reattached. Still having problems though so I checked here.

After re-attaching to \'http://cosmologyathome.org\' I\'m getting these errors but the WU\'s seem to report ok and give credit:
Jan/24/2008 05:19:49|Cosmology@Home|Started upload of wu_011208_110500_2_0_0
Jan/24/2008 05:19:49|Cosmology@Home|Started upload of wu_011208_110500_2_0_1
Jan/24/2008 05:19:51|Cosmology@Home|[error] Error on file upload: no command
Jan/24/2008 05:19:51|Cosmology@Home|[error] Error on file upload: no command
Jan/24/2008 05:19:51|Cosmology@Home|Giving up on upload of wu_011208_110500_2_0_0: fatal upload error
Jan/24/2008 05:19:51|Cosmology@Home|Giving up on upload of wu_011208_110500_2_0_1: fatal upload error
Jan/24/2008 05:19:51|Cosmology@Home|Started upload of wu_011208_110500_2_0_2
Jan/24/2008 05:19:51|Cosmology@Home|Started upload of wu_011208_110500_2_0_3
Jan/24/2008 05:19:53|Cosmology@Home|[error] Error on file upload: no command
Jan/24/2008 05:19:53|Cosmology@Home|[error] Error on file upload: no command
Jan/24/2008 05:19:53|Cosmology@Home|Giving up on upload of wu_011208_110500_2_0_2: fatal upload error
Jan/24/2008 05:19:53|Cosmology@Home|Giving up on upload of wu_011208_110500_2_0_3: fatal upload error
Jan/24/2008 05:19:53|Cosmology@Home|Started upload of wu_011208_110500_2_0_4
Jan/24/2008 05:19:53|Cosmology@Home|Started upload of wu_011208_110500_2_0_5
Jan/24/2008 05:19:55|Cosmology@Home|[error] Error on file upload: no command
Jan/24/2008 05:19:55|Cosmology@Home|[error] Error on file upload: no command
Jan/24/2008 05:19:55|Cosmology@Home|Giving up on upload of wu_011208_110500_2_0_4: fatal upload error
Jan/24/2008 05:19:55|Cosmology@Home|Giving up on upload of wu_011208_110500_2_0_5: fatal upload error
Jan/24/2008 05:20:00|Cosmology@Home|Sending scheduler request: To report completed tasks. Requesting 0 seconds of work, reporting 1 completed tasks
Jan/24/2008 05:20:05|Cosmology@Home|Scheduler request succeeded: got 0 new tasks


Anthony.

Exactly as I posted here. BOINC Manager is reporting upload errors, but the WU\'s are uploading and reporting successfully - at least I assume \'successfully\'; haven\'t had one validate yet as they are new downloads when I re-attached and no matching results have come in yet.

F.
ID: 4661 · Report as offensive
Profile Sou'westerly

Send message
Joined: 1 Jul 07
Posts: 37
Credit: 208,284
RAC: 0
Message 4662 - Posted: 24 Jan 2008, 16:21:02 UTC - in response to Message 4661.  

WU\'s seem to report ok and give credit:


Anthony, it may be reporting OK but it looks like all your results files are failing to upload so there will be nothing for the validator to check and eventually it will fail validation.
Dave.
ID: 4662 · Report as offensive
Profile ohiomike
Avatar

Send message
Joined: 17 Jul 07
Posts: 302
Credit: 5,006,319
RAC: 0
Message 4663 - Posted: 24 Jan 2008, 16:25:23 UTC
Last modified: 24 Jan 2008, 16:26:58 UTC

I give up, I just lost about 100 WU\'s (completed, uploaded, but failed to report and were aborted). Cosmo is suspended until it gets straightened out.

Boinc Button Abuser In Training >My Shrubbers<
ID: 4663 · Report as offensive
Fred

Send message
Joined: 17 Jan 08
Posts: 40
Credit: 228,230
RAC: 0
Message 4664 - Posted: 24 Jan 2008, 16:30:16 UTC - in response to Message 4662.  
Last modified: 24 Jan 2008, 16:33:38 UTC

WU\'s seem to report ok and give credit:


Anthony, it may be reporting OK but it looks like all your results files are failing to upload so there will be nothing for the validator to check and eventually it will fail validation.
Dave.

I hadn\'t stopped / re-started BOINC since going through the detach / re-attach. Have now power-cycled the box and should know in 6 - 7 mins if this has cured this particular problem (for me at least).

F.

[Edit]Quick 6 - 7 mins. Re-booting the box makes no difference. This is still happening to every WU for me since my re-attach to the project.

Any suggestions??
[/Edit]
ID: 4664 · Report as offensive
Profile S@NL - Mellowman
Avatar

Send message
Joined: 20 Nov 07
Posts: 40
Credit: 469,070
RAC: 0
Message 4665 - Posted: 24 Jan 2008, 16:32:19 UTC - in response to Message 4662.  

WU\'s seem to report ok and give credit:


Anthony, it may be reporting OK but it looks like all your results files are failing to upload so there will be nothing for the validator to check and eventually it will fail validation.
Dave.


Hmmm...
Don\'t want to crunch for nothing, so maybe it\'s better to suspend the project for a couple of days.

The longer I live, the more reasons I develop for wanting to die.
ID: 4665 · Report as offensive
Brian Silvers

Send message
Joined: 11 Dec 07
Posts: 420
Credit: 270,580
RAC: 0
Message 4666 - Posted: 24 Jan 2008, 16:32:36 UTC - in response to Message 4661.  
Last modified: 24 Jan 2008, 16:34:00 UTC

BOINC Manager is reporting upload errors, but the WU\'s are uploading and reporting successfully - at least I assume \'successfully\'; haven\'t had one validate yet as they are new downloads when I re-attached and no matching results have come in yet.


I made the mod to the client_state.xml file to report tasks, then did the reattach on my Intel host. I am not experiencing upload issues or reporting issues...

2008-01-24 09:48:40 [Cosmology@Home] Computation for task wu_011508_105234_0_2 finished
2008-01-24 09:48:40 [Cosmology@Home] Starting wu_011308_141806_0_2
2008-01-24 09:48:40 [Cosmology@Home] Starting task wu_011308_141806_0_2 using camb version 205
2008-01-24 09:48:42 [Cosmology@Home] [file_xfer] Started upload of file wu_011508_105234_0_2_0
2008-01-24 09:48:42 [Cosmology@Home] [file_xfer] Started upload of file wu_011508_105234_0_2_1
2008-01-24 09:48:46 [Cosmology@Home] [file_xfer] Finished upload of file wu_011508_105234_0_2_0
2008-01-24 09:48:46 [Cosmology@Home] [file_xfer] Throughput 19511 bytes/sec
2008-01-24 09:48:46 [Cosmology@Home] [file_xfer] Finished upload of file wu_011508_105234_0_2_1
2008-01-24 09:48:46 [Cosmology@Home] [file_xfer] Throughput 26209 bytes/sec
2008-01-24 09:48:46 [Cosmology@Home] [file_xfer] Started upload of file wu_011508_105234_0_2_2
2008-01-24 09:48:46 [Cosmology@Home] [file_xfer] Started upload of file wu_011508_105234_0_2_3
2008-01-24 09:48:50 [Cosmology@Home] [file_xfer] Finished upload of file wu_011508_105234_0_2_2
2008-01-24 09:48:50 [Cosmology@Home] [file_xfer] Throughput 23297 bytes/sec
2008-01-24 09:48:50 [Cosmology@Home] [file_xfer] Finished upload of file wu_011508_105234_0_2_3
2008-01-24 09:48:50 [Cosmology@Home] [file_xfer] Throughput 28432 bytes/sec
2008-01-24 09:48:50 [Cosmology@Home] [file_xfer] Started upload of file wu_011508_105234_0_2_4
2008-01-24 09:48:50 [Cosmology@Home] [file_xfer] Started upload of file wu_011508_105234_0_2_5
2008-01-24 09:48:54 [Cosmology@Home] [file_xfer] Finished upload of file wu_011508_105234_0_2_4
2008-01-24 09:48:54 [Cosmology@Home] [file_xfer] Throughput 30982 bytes/sec
2008-01-24 09:48:54 [Cosmology@Home] [file_xfer] Finished upload of file wu_011508_105234_0_2_5
2008-01-24 09:48:54 [Cosmology@Home] [file_xfer] Throughput 2993 bytes/sec
2008-01-24 10:13:21 [Cosmology@Home] Sending scheduler request: Requested by user
2008-01-24 10:13:21 [Cosmology@Home] Reporting 1 tasks
2008-01-24 10:13:26 [Cosmology@Home] Scheduler RPC succeeded [server version 601]
2008-01-24 10:13:26 [Cosmology@Home] Deferring communication for 6 sec
2008-01-24 10:13:26 [Cosmology@Home] Reason: requested by project
ID: 4666 · Report as offensive
Stevea

Send message
Joined: 14 Oct 07
Posts: 22
Credit: 1,084,550
RAC: 0
Message 4667 - Posted: 24 Jan 2008, 16:38:07 UTC
Last modified: 24 Jan 2008, 16:44:25 UTC

Woke to to more upload errors, detached again, and used the new url from the front page, without the www. that I was using from last night. Re-attached and downloaded camb 2.05 and am crunching again.

Now waiting to see if the fist wu uploads without failure....

We shall see...


Are we to use the

http://www.cosmologyathome.org/ this one was erroring out from last nights reset

or the

http://cosmologyathome.org/ I am using this one now with camb 2.05

?

[/quote]
http://cosmologyathome.org/
[/quote]

OK good to go then...
ID: 4667 · Report as offensive
Profile Jayargh
Volunteer moderator
Volunteer tester
Avatar

Send message
Joined: 25 Jun 07
Posts: 508
Credit: 2,282,158
RAC: 0
Message 4668 - Posted: 24 Jan 2008, 16:41:48 UTC - in response to Message 4667.  

Woke to to more upload errors, detached again, and used the new url from the front page, without the www. that I was using from last night. Re-attached and downloaded camb 2.05 and am crunching again.

Now waiting to see if the fist wu uploads without failure....

We shall see...


Are we to use the

http://www.cosmologyathome.org/

or the

http://cosmologyathome.org/

?

http://cosmologyathome.org/
ID: 4668 · Report as offensive
Profile Sou'westerly

Send message
Joined: 1 Jul 07
Posts: 37
Credit: 208,284
RAC: 0
Message 4670 - Posted: 24 Jan 2008, 16:48:08 UTC - in response to Message 4666.  

I made the mod to the client_state.xml file to report tasks, then did the reattach on my Intel host. I am not experiencing upload issues or reporting issues...

Brian, did you edit the upload handler URL for each of the 6 output files for each WU or just the project URL? Dave.
ID: 4670 · Report as offensive
Brian Silvers

Send message
Joined: 11 Dec 07
Posts: 420
Credit: 270,580
RAC: 0
Message 4671 - Posted: 24 Jan 2008, 16:54:45 UTC - in response to Message 4670.  
Last modified: 24 Jan 2008, 16:57:44 UTC

I made the mod to the client_state.xml file to report tasks, then did the reattach on my Intel host. I am not experiencing upload issues or reporting issues...

Brian, did you edit the upload handler URL for each of the 6 output files for each WU or just the project URL? Dave.


I didn\'t have anything to upload, so I just changed the scheduler_url... I then detached and attached through the manager using cosmologyathome.org. It downloaded 2.05 and several tasks, and all has appeared to work normally...

Edit: Oh, and the editing of the file happened BEFORE the detach/reattach so that I could report 2 tasks, then I did the detach/reattach and downloading of the task that I later uploaded without issue...so I\'m confused as to why I have no problems while the rest of you are fretting about... ;-)
ID: 4671 · Report as offensive
Profile Dingo
Avatar

Send message
Joined: 28 Jun 07
Posts: 10
Credit: 1,355,189
RAC: 48
Message 4673 - Posted: 24 Jan 2008, 16:57:37 UTC

Looks like my XP pc\'s have reported OK and have credit http://cosmologyathome.org//results.php?hostid=778

None of my Linux PC\'s (10 of them) have reported and are still getting the Incomplete request error. I have set it to no more work but I wasn\'t getting any anyway but when they upload I will detach and re attach.

If I just sit and wait will this sort itself out ??




ID: 4673 · Report as offensive
Previous · 1 · 2 · 3 · 4 · 5 · 6 . . . 9 · Next

Forums : Technical Support : Upload/Download Server Problems